Celestron CPC Edge HD 11 "blank hand control"

General astronomy discussion
Posts: 1
Joined: Sat Jul 06, 2013 6:22 pm

Celestron CPC Edge HD 11 "blank hand control"

Postby Chad055 » Sat Jul 06, 2013 6:36 pm

I have the Celestron Deluxe HD 11 bought Dec 2011. It worked great until I tried to connect the scope to SkiFi and Skysafari Pro. I got the message "no telescope found". I used all of the connections directed by the instructions. I connected back to the HC and when I powered on the scope, the hand control displayed "initializing" then went blank. I have updated the HC to the latest firmware which verified as successful. Then when I attempt to update the motor control, I get the message "no scope found". I have loaded the fix NXS 99.99 HC bypass from nextstarsite to try a bypass but still the same thing - no scope found. I had the older HC then bought the newer Nexstar+ HC. The same thing happened, power up the scope and "initializing" then blank screen. It appears to me this issue is somewhere in the mount, either the connections boards or the motor control board. I wanted to see if anyone might be familiar with this issue before I sent my scope back to Celestron to be repaired.

I am using the scope supplied RS 232 cable, HC unit, and RS 232 USB adapter to update. I have tried connecting to the aux ports on scope per Celestrons suggestion but same thing.


Post Extras:

Posts: 1
Joined: Tue Jan 06, 2015 9:05 pm

Re: Celestron CPC Edge HD 11 "blank hand control"

Postby sspikali » Tue Jan 06, 2015 9:29 pm

I have the same problem as Chad. Have tried everythink: upgrading HC with NXS 99,99 file, upgrading MC through PC port (the MCupdate error : no device found on port COM1). Does anyone know, how to solve the problem?

Nice geetings Nace

Posts: 26
Joined: Fri Sep 20, 2013 11:52 am

Re: failure of hand control to connect to mount

Postby RossW » Wed Jan 07, 2015 2:21 pm

A similar thing happened to a friend's SkyWatcher unit last year: the hand-control worked OK stand-alone but wouldn't connect to his mount.
I found (with a magnifying-glass) that one of the contacts in the RJ45 socket on his mount had bent sideways (maybe caused by him trying to insert the plug at an angle?) and was shorting to one of the neighbouring contacts. I managed to push it back straight using a sewing-needle and the unit has worked fine ever since.

Return to “Astronomy”

Who is online

Users browsing this forum: No registered users and 1 guest